nach unten

Welchen USB-3-Hub? (Einige Messungen zu Schreib/Leseraten von HDD)

Im Thread https://iszene.com/thread-179594.html ging es um eine SDXC Karte.

In der Zwischenzeit ist mein 4K-Display mit integriertem USB-3-Hub eingetroffen und ich habe mit dem im obigen Thread empfohlenen Tool Disk Speed Test einige Platten in verschiedenen Konstellationen durchgemessen.

Alle Details inkl. genauer Rahmenbedingungen hier:

http://borumat.de/+macbook/usb-3-schreib-lese-rate

Wenn man sich die Ergebnisse ansieht, dann scheint es so zu sein, dass weder das Festplattendock noch der im Display integrierte Hub ein Flaschenhals ist.

Im Freundeskreis besitzt leider niemand einen USB-3-Hub.

Kann jemand von Euch einen empfehlen oder hat sogar schonmal selber getestet, welche Schreib/Leserate eine HDD an ihm erzielt?

Aus reiner Neugier würde mich ja interessieren, welche Raten an einem Thunderbolt-Dock (was mir zu kostspielig ist) erzielt werden.
Besitzt jemand von Euch eines und hätte Lust mal eine Messung zu berichten?

Ein weiteres Tool zum Messen der Schreib/Leserate kannte im oben erwähnten Thread niemand.
Ich habe noch das kostenlose xbench.com gefunden.
Anders als "Blackmagic" erlaubt es auch ein Kopieren der Ergebnisse in die Zwischenablage.
(Dieser Beitrag wurde zuletzt bearbeitet: 11.04.2016, 00:30 von fermion.)
@Danke Quote
Dell spricht in der Beschreibung von Highspeed USB3.0.
Highspeed entsprechen 480Mbit/s also wie USB2.0
Anscheinend hat Dell bei USB nur die Stromversorgung auf USB3.0 angehoben.

Was sagt denn das MBP in den Systeminformationen zu den USB-Hub des Display?
@Danke Quote
USB 3.0 Sony 2,5 an USB 3.0 Hub, der im USB 3.0 Port steckt:

* MB/s = 1,000,000 bytes/s [SATA/600 = 600,000,000 bytes/s]
* KB = 1000 bytes, KiB = 1024 bytes

Sequential Read (Q= 32,T= 1) : 40.735 MB/s
Sequential Write (Q= 32,T= 1) : 40.499 MB/s
Random Read 4KiB (Q= 32,T= 1) : 0.470 MB/s [ 114.7 IOPS]
Random Write 4KiB (Q= 32,T= 1) : 0.948 MB/s [ 231.4 IOPS]
Sequential Read (T= 1) : 40.057 MB/s
Sequential Write (T= 1) : 40.479 MB/s
Random Read 4KiB (Q= 1,T= 1) : 0.399 MB/s [ 97.4 IOPS]
Random Write 4KiB (Q= 1,T= 1) : 0.910 MB/s [ 222.2 IOPS]

Test : 1024 MiB [F: 60.3% (280.8/465.8 GiB)] (x3) [Interval=5 sec]
Date : 2016/04/10 21 02
OS : Windows 10 Professional [10.0 Build 10586] (x64)



Wie oben direkt am Thinkpad usb 3 Port

-----------------------------------------------------------------------
CrystalDiskMark 5.1.2 x64 © 2007-2016 hiyohiyo
Crystal Dew World : http://crystalmark.info/
-----------------------------------------------------------------------
* MB/s = 1,000,000 bytes/s [SATA/600 = 600,000,000 bytes/s]
* KB = 1000 bytes, KiB = 1024 bytes

Sequential Read (Q= 32,T= 1) : 69.281 MB/s
Sequential Write (Q= 32,T= 1) : 69.043 MB/s
Random Read 4KiB (Q= 32,T= 1) : 0.478 MB/s [ 116.7 IOPS]
Random Write 4KiB (Q= 32,T= 1) : 0.946 MB/s [ 231.0 IOPS]
Sequential Read (T= 1) : 69.207 MB/s
Sequential Write (T= 1) : 68.156 MB/s
Random Read 4KiB (Q= 1,T= 1) : 0.403 MB/s [ 98.4 IOPS]
Random Write 4KiB (Q= 1,T= 1) : 0.899 MB/s [ 219.5 IOPS]

Test : 1024 MiB [F: 60.3% (280.8/465.8 GiB)] (x3) [Interval=5 sec]
Date : 2016/04/10 2144
OS : Windows 10 Professional [10.0 Build 10586] (x64)


Test mit Festplatten cache folgt, muss erst neu starten....
@Danke Quote
-----------------------------------------------------------------------
CrystalDiskMark 5.1.2 x64 © 2007-2016 hiyohiyo
Crystal Dew World : http://crystalmark.info/
-----------------------------------------------------------------------
* MB/s = 1,000,000 bytes/s [SATA/600 = 600,000,000 bytes/s]
* KB = 1000 bytes, KiB = 1024 bytes

Sequential Read (Q= 32,T= 1) : 69.283 MB/s
Sequential Write (Q= 32,T= 1) : 68.733 MB/s
Random Read 4KiB (Q= 32,T= 1) : 0.476 MB/s [ 116.2 IOPS]
Random Write 4KiB (Q= 32,T= 1) : 0.930 MB/s [ 227.1 IOPS]
Sequential Read (T= 1) : 68.369 MB/s
Sequential Write (T= 1) : 67.939 MB/s
Random Read 4KiB (Q= 1,T= 1) : 0.393 MB/s [ 95.9 IOPS]
Random Write 4KiB (Q= 1,T= 1) : 0.894 MB/s [ 218.3 IOPS]

Test : 1024 MiB [F: 60.3% (280.8/465.8 GiB)] (x3) [Interval=5 sec]
Date : 2016/04/10 21#35
OS : Windows 10 Professional [10.0 Build 10586] (x64)
@Danke Quote
(10.04.2016, 21:02)kuddel schrieb: Dell spricht in der Beschreibung von Highspeed USB3.0.
Highspeed entsprechen 480Mbit/s also wie USB2.0
Anscheinend hat Dell bei USB nur die Stromversorgung auf USB3.0 angehoben.

Was sagt denn das MBP in den Systeminformationen zu den USB-Hub des Display?

Wesentlich ist ja, dass die Kaskadierung und der Chip des USB-Hubs im Display offenbar keinerlei Einbußen der Raten gegenüber der direkten Anbindung am Macbook verursachen.
Was mich überrascht hat.

In den Systeminformationen "Grafik/Monitore" gibt es keine Rubrik "USB".

Die Systeminformation "USB" liefert:

Zitat:USB 3.0 Bus:

  Treiber für Host-Controller:    AppleUSBXHCIWPT
  PCI Geräte-ID:    0x9cb1
  PCI Revisions-ID:    0x0003
  PCI Hersteller-ID:    0x8086

USB5534B:

  Produkt-ID:    0x5534
  Hersteller-ID:    0x0424  (SMSC)
  Version:    60.80
  Geschwindigkeit:    Bis zu 5 Gbit/s
  Hersteller:    SMSC
  Standort-ID:    0x14400000 / 4
  Verfügbare Stromstärke (mA):    1800
  Erforderliche Stromstärke (mA):    0
  Zusätzlicher Betriebsstrom (mA):    0

Bluetooth-USB-Host-Controller:

  Produkt-ID:    0x8290
  Hersteller-ID:    0x05ac (Apple Inc.)
  Version:    1.19
  Geschwindigkeit:    Bis zu 12 MBit/s
  Hersteller:    Broadcom Corp.
  Standort-ID:    0x14300000 / 7
  Verfügbare Stromstärke (mA):    1000
  Erforderliche Stromstärke (mA):    0
  Zusätzlicher Betriebsstrom (mA):    0
  Integriert:    Ja

USB2134B:

  Produkt-ID:    0x2134
  Hersteller-ID:    0x0424  (SMSC)
  Version:    60.80
  Geschwindigkeit:    Bis zu 480 MBit/s
  Hersteller:    SMSC
  Standort-ID:    0x14100000 / 2
  Verfügbare Stromstärke (mA):    1000
  Erforderliche Stromstärke (mA):    0
  Zusätzlicher Betriebsstrom (mA):    0

USB Audio DAC   :

  Produkt-ID:    0x2704
  Hersteller-ID:    0x08bb  (Texas Instruments Japan)
  Version:    1.00
  Geschwindigkeit:    Bis zu 12 MBit/s
  Hersteller:    Burr-Brown from TI             
  Standort-ID:    0x14110000 / 6
  Verfügbare Stromstärke (mA):    1000
  Erforderliche Stromstärke (mA):    500
  Zusätzlicher Betriebsstrom (mA):    0
@Danke Quote
Was einen USB-Hub angeht: Ich setze überall USB-Hubs von Anker ein. Die Verarbeitung ist spitze, die Optik sieht sehr gut aus, es gibt viele Modelle zur Auswahl, sie sind sehr preisgünstig, und das wichtigste: Die Transferraten stimmen. Nutze verschiedene USB-3.0-HDDs, alle erzielen an den Anker-USB-Hubs (konkret geht es um ein 9-Port-Modell mit externer Stromversorgung, und ein 3-Port-Modell mit on-Line-Stromversorgung und einem integrierten Ethernet-Port) dieselbe Leistung wie direkt am iMac. Haben auch noch nie Probleme gemacht, was Erkennung oder Verbindungsstabilität angeht. Die kann ich also gut empfehlen Zwinkern
@Danke Quote
@LukeLR
Danke.
Ich verwende seit 2 Jahren einen USB-Akku von Anker und bin auch zufrieden.

Zu Deinem 9-Port-Modell:
Die c't schrieb, dass in Hubs mit mehr als 4 Ports intern kaskadiert wird. Also: Hub(s) im Hub.
Sind Dir schonmal Unterschiede der Ports aufgefallen?

Zum Netzteil des 9-Port-Modells:
5A ist ganz schön wenig.

Schade finde ich, dass Anker gar keine Schalter pro Port verbaut.

Edle Gehäuse sind mir selber völlig unwichtig. Das Ding wird eh an die Rückseite des Displays geklebt und ist daher aus dem Blickfeld.
(Dieser Beitrag wurde zuletzt bearbeitet: 12.04.2016, 23:41 von fermion.)
@Danke Quote
Naja, also Schalter beim USB-Hub fand ich schon immer unnötig, wenn ich ein Gerät nicht benutzen möchte, stört es ja nicht, wenn es trotzdem eingesteckt ist, und ansonsten stecke ich es halt aus Biggrin Aber klar, es ist schade, dass sie für diejenigen, die sich das wünschen, kein Modell im Programm haben.

Die Angefragten Details werde ich jedenfalls gerne recherchieren Zwinkern Denn es ist ja tatsächlich so, dass Anker sich mit Details zurückhält Zwinkern Schon vorab kann ich jedenfalls sagen, dass das Netzteil sehr kräftig ist und mit 12V arbeitet, ich glaube, es waren sogar über 50W Zwinkern
(Dieser Beitrag wurde zuletzt bearbeitet: 12.04.2016, 23:45 von LukeLR.)
@Danke Quote
Zuerst mal Screenshots von der Systemkonfiguration am iMac mit und ohne USB-Hub:
Ohne USB-Hub:
   
Mit USB-Hub:
   
Wie es scheint, sind da kaskadierende USB-Hubs verbaut, und irgendwie irritieren mich gerade die USB 2.0-Angaben... Habe eigentlich bisher nie Unterschiede feststellen können...

Für die Detailinformationen hier auch nochmal der vollständige Output des System Profilers:

Code:
USB 3.0 Bus:

 Host Controller Driver: AppleUSBXHCIPPT
 PCI Device ID: 0x1e31
 PCI Revision ID: 0x0004
 PCI Vendor ID: 0x8086

USB3.0 Hub             :

 Product ID: 0x0812
 Vendor ID: 0x2109  (VIA Labs, Inc.)
 Version: 90.91
 Speed: Up to 5 Gb/sec
 Manufacturer: VIA Labs, Inc.        
 Location ID: 0x14600000 / 18
 Current Available (mA): 1800
 Current Required (mA): 0
 Extra Operating Current (mA): 0

USB3.0 Hub             :

 Product ID: 0x0812
 Vendor ID: 0x2109  (VIA Labs, Inc.)
 Version: 90.91
 Speed: Up to 5 Gb/sec
 Manufacturer: VIA Labs, Inc.        
 Location ID: 0x14640000 / 21
 Current Available (mA): 1800
 Current Required (mA): 0
 Extra Operating Current (mA): 0

USB3.0 Hub             :

 Product ID: 0x0812
 Vendor ID: 0x2109  (VIA Labs, Inc.)
 Version: 90.91
 Speed: Up to 5 Gb/sec
 Manufacturer: VIA Labs, Inc.        
 Location ID: 0x14644000 / 22
 Current Available (mA): 1800
 Current Required (mA): 0
 Extra Operating Current (mA): 0

Apple USB SuperDrive:

 Product ID: 0x1500
 Vendor ID: 0x05ac  (Apple Inc.)
 Version: 2.02
 Serial Number: KMZE23L5233        
 Speed: Up to 480 Mb/sec
 Manufacturer: Apple Inc.
 Location ID: 0x14300000 / 4
 Current Available (mA): 1000
 Current Required (mA): 500
 Extra Operating Current (mA): 600

USB2.0 Hub             :

 Product ID: 0x2812
 Vendor ID: 0x2109  (VIA Labs, Inc.)
 Version: 90.90
 Speed: Up to 480 Mb/sec
 Manufacturer: VIA Labs, Inc.        
 Location ID: 0x14200000 / 17
 Current Available (mA): 1000
 Current Required (mA): 0
 Extra Operating Current (mA): 0

USB2.0 Hub             :

 Product ID: 0x2812
 Vendor ID: 0x2109  (VIA Labs, Inc.)
 Version: 90.90
 Speed: Up to 480 Mb/sec
 Manufacturer: VIA Labs, Inc.        
 Location ID: 0x14240000 / 19
 Current Available (mA): 1000
 Current Required (mA): 0
 Extra Operating Current (mA): 0

USB2.0 Hub             :

 Product ID: 0x2812
 Vendor ID: 0x2109  (VIA Labs, Inc.)
 Version: 90.90
 Speed: Up to 480 Mb/sec
 Manufacturer: VIA Labs, Inc.        
 Location ID: 0x14244000 / 20
 Current Available (mA): 1000
 Current Required (mA): 0
 Extra Operating Current (mA): 0
(Dieser Beitrag wurde zuletzt bearbeitet: 13.04.2016, 00:03 von LukeLR.)
@Danke Quote
Und hier nochmal zwei Fotos, einmal von der Unterseite des Gehäuses…

… und einmal vom Netzteil:

Wie sich zeigt, bestätigt sich mein Verdacht, dass das Netzteil 12 Volt abgibt, und tatsächlich mit 60W sehr leistungsstark ist.
(Dieser Beitrag wurde zuletzt bearbeitet: 13.04.2016, 00:03 von LukeLR.)
Angehängte Dateien Bild(er)
       
@Danke Quote
Die Kaskadierung hatte ja schon die c't im Artikel erwähnt. Offenbar existieren keine Chips, die mehr als 4 Ports drauf haben.

Zum Netzteil:
60W ist ordentlich.
Nominell wären pro Port 5V * 0,9A  = 4,5W nötig.
Bei 9 Ports als 4,5W *  9 = 40,5W.
Also satte Reserve.

Danke für Deine ausführliche Antwort und die Bilder Smiley

Deine Gleichgültigkeit gegenüber länger ungenutzten Geräten, die dennoch die ganze Zeit verbunden sind, bzw. Deine Freude am Kabelstöpseln teile ich nicht. Ich bekenne meine Schaltfreudigkeit Smiley

P.S.: Falls Mitleser aus Berlin mal Strom und Spannung ihrer USB-Geräte vermessen wollen: ich verleihe mein USB-3-Multimeter von Drok gern.
(Dieser Beitrag wurde zuletzt bearbeitet: 13.04.2016, 01:28 von fermion.)
@Danke Quote
Kein Problem, gerne doch Zwinkern So ein USB-Multimeter suche ich momentan auch, die von DROK sehen ja wirklich sehr gut aus Zwinkern Kann man die auch woanders bestellen als bei Amazon?
@Danke Quote
Es ist leider genau das eingetreten, was ich so gerne vermieden hätte:

Ein Gerät funktioniert mit dem Hub nicht.

Genauer:

Gestern traf mein Hub ein. Anker A7517011. http://de.anker.com/product/A7517011

Der Wireless-Sender meines Stifttabletts Wacom Intuos 5 funktioniert am Port des Macbooks.
Er funktioniert nicht am Anker-Hub.

Am Windows-PC (an dessen USB-3-Port) funktioniert der Wireless-Sender am Anker-Hub dagegen problemlos.

Vermutlich kann ich mir ein Kaufen und Testen eines anderen Hubs sparen. Das würde in ein Forschungsprojekt ausarten.

Ärgerlich.

Eine Website mit Tests konkreter Hubs und konkreter Geräte habe ich nicht gefunden.

Die Implementation von USB-3 scheint bei OS X kaputt zu sein.
@Danke Quote
Vermeiden Sie es Geräte mit hohem Stromverbrauch, wie zum Beispiel HDDs zu verbinden. Der Hub synchronisiert Tablets und andere Geräte mit höherem Strominput, lädt diese aber nicht auf.
@Danke Quote
@fermion Kannst du mal gucken, was der System Profiler sagt, wenn du a) weder Hub noch Stick, b) Hub und c) Hub mit Stick angeschlossen hast?
@Danke Quote
@Denner
Der Sender verbraucht 20mA.

@Luke
a)
USB 3.0 Bus:

Treiber für Host-Controller: AppleUSBXHCIWPT
PCI Geräte-ID: 0x9cb1
PCI Revisions-ID: 0x0003
PCI Hersteller-ID: 0x8086

Bluetooth-USB-Host-Controller:

Produkt-ID: 0x8290
Hersteller-ID: 0x05ac (Apple Inc.)
Version: 1.19
Geschwindigkeit: Bis zu 12 MBit/s
Hersteller: Broadcom Corp.
Standort-ID: 0x14300000 / 2
Verfügbare Stromstärke (mA): 1000
Erforderliche Stromstärke (mA): 0
Zusätzlicher Betriebsstrom (mA): 0
Integriert: Ja

b)

USB 3.0 Bus:

Treiber für Host-Controller: AppleUSBXHCIWPT
PCI Geräte-ID: 0x9cb1
PCI Revisions-ID: 0x0003
PCI Hersteller-ID: 0x8086

USB3.0 Hub :

Produkt-ID: 0x0812
Hersteller-ID: 0x2109 (VIA Labs, Inc.)
Version: b.e1
Geschwindigkeit: Bis zu 5 Gbit/s
Hersteller: VIA Labs, Inc.
Standort-ID: 0x14500000 / 12
Verfügbare Stromstärke (mA): 1800
Erforderliche Stromstärke (mA): 0
Zusätzlicher Betriebsstrom (mA): 0

Bluetooth-USB-Host-Controller:

Produkt-ID: 0x8290
Hersteller-ID: 0x05ac (Apple Inc.)
Version: 1.19
Geschwindigkeit: Bis zu 12 MBit/s
Hersteller: Broadcom Corp.
Standort-ID: 0x14300000 / 2
Verfügbare Stromstärke (mA): 1000
Erforderliche Stromstärke (mA): 0
Zusätzlicher Betriebsstrom (mA): 0
Integriert: Ja

USB2.0 Hub :

Produkt-ID: 0x2812
Hersteller-ID: 0x2109 (VIA Labs, Inc.)
Version: b.e0
Geschwindigkeit: Bis zu 480 MBit/s
Hersteller: VIA Labs, Inc.
Standort-ID: 0x14200000 / 13
Verfügbare Stromstärke (mA): 1000
Erforderliche Stromstärke (mA): 0
Zusätzlicher Betriebsstrom (mA): 0


c)

USB 3.0 Bus:

Treiber für Host-Controller: AppleUSBXHCIWPT
PCI Geräte-ID: 0x9cb1
PCI Revisions-ID: 0x0003
PCI Hersteller-ID: 0x8086

USB3.0 Hub :

Produkt-ID: 0x0812
Hersteller-ID: 0x2109 (VIA Labs, Inc.)
Version: b.e1
Geschwindigkeit: Bis zu 5 Gbit/s
Hersteller: VIA Labs, Inc.
Standort-ID: 0x14500000 / 12
Verfügbare Stromstärke (mA): 1800
Erforderliche Stromstärke (mA): 0
Zusätzlicher Betriebsstrom (mA): 0

Bluetooth-USB-Host-Controller:

Produkt-ID: 0x8290
Hersteller-ID: 0x05ac (Apple Inc.)
Version: 1.19
Geschwindigkeit: Bis zu 12 MBit/s
Hersteller: Broadcom Corp.
Standort-ID: 0x14300000 / 2
Verfügbare Stromstärke (mA): 1000
Erforderliche Stromstärke (mA): 0
Zusätzlicher Betriebsstrom (mA): 0
Integriert: Ja

USB2.0 Hub :

Produkt-ID: 0x2812
Hersteller-ID: 0x2109 (VIA Labs, Inc.)
Version: b.e0
Geschwindigkeit: Bis zu 480 MBit/s
Hersteller: VIA Labs, Inc.
Standort-ID: 0x14200000 / 13
Verfügbare Stromstärke (mA): 1000
Erforderliche Stromstärke (mA): 0
Zusätzlicher Betriebsstrom (mA): 0

Wacom Wireless Receiver:

Produkt-ID: 0x0084
Hersteller-ID: 0x056a (WACOM Co., Ltd.)
Version: 1.11
Geschwindigkeit: Bis zu 12 MBit/s
Hersteller: Wacom Co.,Ltd.
Standort-ID: 0x14210000 / 14
Verfügbare Stromstärke (mA): 1000
Erforderliche Stromstärke (mA): 98
Zusätzlicher Betriebsstrom (mA): 0
(Dieser Beitrag wurde zuletzt bearbeitet: 15.04.2016, 23:51 von fermion.)
@Danke Quote
Moment, also gibt es auch keine Änderung, wenn du den Hub ansteckst?
@Danke Quote
@Luke
Du warst zu schnell Smiley Ich hatte "Informationen aktualisieren" zu spät gesehen. Siehe oben die vollständige Liste.

Anker schreibt ja auf der verlinkten Produktseite:

Zitat:Kompatibilität: 
2.4 GHz Wireless Geräte, MIDI Geräte und einige spezielle USB 3.0 Geräte werden möglicherweise nicht unterstützt. Bitte versuchen Sie den Host Port oder eine USB 2.0 Verbindung zu verwenden.


Kann man per Software einen einzelnen Port "umdeklarieren von USB-3 auf USB-2"?
Wäre das ein Lösungsansatz?

Oder kennt ihr andere Hubs, die mit 2.4 GHz Wireless Geräten kompatibel sind?
(Dieser Beitrag wurde zuletzt bearbeitet: 16.04.2016, 07:59 von fermion.)
@Danke Quote
Okay, da war ich wohl zu schnell Biggrin Du kannst zum Beispiel ein USB 2.0-Verlängerungskabel dazwischen stecken, damit kann man manchmal die Abwärtskompatibilität erzwingen (auch wenn's logisch wenig Sinn macht)
@Danke Quote
Hey, ganz herzlichen Dank! Smiley

So funktioniert es einwandfrei.

Sogar wenn der Hub am Display steckt statt direkt am MB.

Die Entfernung des Senders zum Hub spielt übrigens keine Rolle. Ich habe den Sender direkt auf den Hub gelegt, also genauso nah dran, als wenn er ohne Verlängerung drin stecken würde.

Ich freu' mich!
@Danke Quote



Thema abonnieren


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Alle Foren als gelesen markieren
Top top home iszene.com